Open Money : Solution de crédit instantané libre

Open Money est un projet de logiciel libre de paiement et de crédit instantané.

L’industrie informatique voit le commerce électronique, ou e-commerce, comme un moyen de faire du E-business. C’est l’utilisation dans de nombreuses activitées de moyens électroniques pour réaliser des affaires. Ce moyen se développe de plus en plus et deviendra prochainement un des secteur majeur de l’économie. Selon Forrester Research, le commerce électronique à généré quelques 12,2 milliards de dollars de vente annuel au Etats-Unis en 2003.

Les progrès technologiques liés à l’informatique et à Internet sont à la base du développement de la « société de l’Information », qui succède à la société industrielle. Bien que cette nouvelle forme de société soit à la source d’une forte croissance économique, elle a également mis en place de nouvelles formes d’exclusion que l’on rassemble sous le nom de fracture numérique.

Open Money se veut une alternatives libre aux logiciels de e-commerce propriétaires actuels (Ebay, Paypal). Un logiciel libre est un logiciel tel que toute personne qui en possède une copie a le droit de l’utiliser, de l’étudier, de le modifier et de le redistribuer. Ce droit est donné par une licence libre, Licence publique générale GNU.

Recrutement

Dans le cadre du développement d’une solution de crédit et paiement en ligne open source, nous recherchons un stagiaire ayant des bases en PHP et qui soit intéressé par le e-commerce.

Vous travaillerez avec une communauté de développeurs, et verrez comment elle gagne de l’argent avec des logiciels libres.

Connaissances souhaitées :

*Finances

*Informatique
oXML
oJavascript
oMysql
oPHP
oXHTML

Qualitées recherchées:

*intérêt pour les logiciels libres
*savoir travailler en équipe

Disponibilité : ASAP

Contrat : Stage

Création de poste : oui

Rémunération : En fonction du profil

Région : Ile de France

Télécharger la maquette

Contact : Envoyez votre CV + Lettre de motivation + Travaux

Piphilologie

Pi.pngMa définition de Piphilologie : Création et utilisation de mnémotechniques pour retenir la constante Pi. Comme par exemple, un poème en français. Le nombre de lettres de chaque mot correspond à une décimale.

Et donc, voici mon programme que j'ai publié sur le réseau codes sources :

http://www.csharpfr.com/codes/PIPHILOLOGIE_36800.aspx 

J'ai utilisé SharpDevelop, un environnement de développement open source et je me suis aidé de l'article de wikipédia sur Pi et de la version anglaise concernant ce sujet.

Rock, Paper, Scissors

C'est ma version en anglais du jeu de Pierre , Papier, Ciseau que j'ai fait avec SharpDevelop rock battle. Vous pouvez me la demander en me contactant par courriel.

Rock, Paper, Scissors is a popular hand game most often played by children. The objective is to defeat the opponent by selecting a weapon which defeats their choice. If players choose the same weapon, the game is a tie and is played again.

Typically, the short game is repeated so that the person who wins two out of three or three out of five times wins the entire game.

Mathematically optimal play (according to game theory) is a simple matter of selecting randomly, and so the game may be considered trivial in that sense when played in a way that eliminates psychology, as with a computer. But "optimal" in this sense means only "incapable of being defeated more than expected by chance", while it does not imply that the random strategy is best at taking advantage of a suboptimal opponent. In fact, if the opponent is human or a non-random program, it is almost certain that he plays suboptimally and that a modified strategy can exploit that weakness.

Texte disponible sous GNU Free Documentation License.

Algorithme du Jaken

rockAlgo Jaken

La version complète du jeu est disponible ici :

http://www.angelfire.com/blog/gya/Jaken.7z 

Vous pouvez également consulter le code source sur Csharpfr.com

http://www.csharpfr.com/codes/JEU-PIERRE-FEUILLE-CISEAUX-JANKENPON_34692.aspx 

Variables

scor, scor2, choix : entierstexte, choix2 : caractères
DEBUT

Afficher "Jeu de Jaken"
Afficher "Licence publique générale GNU"   

scor <- 0
scor2 <- 0
choix <- 0
choix2 <- "pierre"

Répéter
    Afficher " "
    Répéter
        Afficher "pierre, papier ou ciseau?"
        Saisir texte
    Jusqu'à texte="pierre" ou texte="papier" ou texte="ciseau"

si texte = "pierre" alors
        choix <- 0
    finsi
    si texte = "papier" alors
        choix <- 1
    finsi
    si texte = "ciseau" alors
        choix <- 2
    finsi

Afficher " "
    Afficher "joueur1: ", texte       

nb <- aléatoire(2)

si nb = 0 alors
        choix2 <- "pierre"
    finsi
    si nb = 1 alors
        choix2 <- "papier"
    finsi
    si nb = 2 alors
        choix2 <- "ciseau"
    finsi   

Afficher "joueur2: ", choix2
    Afficher " "

si choix=0 et nb=0 alors
        Afficher "Partie Nulle."
    sinon
        si choix=0 et nb=1 alors
            Afficher "Le papier recouvre la pierre."
            scor2 <- scor2 + 1
        sinon
            si choix=0 et nb=2 alors
                Afficher "La pierre casse les ciseaux."
                scor <- scor + 1
            finsi
        finsi
    finsi

si choix=1 et nb=0 alors
        Afficher "Le papier enveloppe la pierre."
        scor <- scor + 1
    sinon
        si choix=1 et nb=1 alors
            Afficher "Partie Nulle."
        sinon
            si choix=1 et nb=2 alors
                Afficher "Le ciseau coupe le papier."
                scor2 <- scor2 + 1
            finsi
        finsi
    finsi

si choix=2 et nb=0 alors
        Afficher "La pierre casse le ciseau."
        scor2 <- scor2 + 1
    sinon
        si choix=2 et nb=1 alors
            Afficher "Le ciseau coupe le papier."
            scor <- scor + 1
        sinon
            si choix=2 et nb=2 alors
                Afficher "Partie Nulle."
            finsi
        finsi
    finsi

Afficher " "
    Afficher "Les scores sont :"
    Afficher "Joueur1 : ", scor
    Afficher "Joueur2 : ", scor2
    Afficher " "

Répéter
        Afficher "Encore une partie?(O/N)"
        Saisir texte
        texte <- agrandir(texte)
    Jusqu'à texte="N" ou texte="O"

jusqu'à texte="N"

FIN

WikiMonnaie

WIKIMONAIE.png"La wikimonnaie est un système de crédit mutuel utilisé par les Wikipédiens anglophones. Son principe est de créer une économie où les personnes peuvent proposer un travail sur Wikipédia contre de la wikimonnaie ou remplir une tâche proposée pour en gagner.

Tout contributeur régulier (actif depuis un mois et ayant au moins 200 éditions à son actif) peut ouvrir un compte sur cette page et se voit offrir 20 unités de wikimonnaie (W) indivisibles. Cette monnaie virtuelle pourra alors servir à s'échanger des services.

Les comptes de chacun sont publics et maintenus dans la section WikiBanque de cette page. Pour transférer la wikimonnaie d'un compte à un autre, il suffit d'éditer les montants des comptes. Seul le débiteur transfère les W de son compte vers celui qui a répondu à son offre.

Pourquoi essayer de récolter de la wikimonnaie ? Tout simplement, cela vous permettra d'investir dans des domaines qui vous tiennent à cœur. Le temps que vous investissez pour d'autres vous permettra aussi de demander du temps à d'autres. Rien ne vous empêche de vous regrouper pour proposer une offre alléchante ! Souvenez vous que la WikiMonnaie n'est qu'une monnaie virtuelle et ne doit pas être prise trop au sérieux !"

Texte disponible sous GNU Free Documentation License.

J'ai crée un programme qui reprend cette idée. Il est consultable ici :

http://www.csharpfr.com/codes/WIKIMONNAIE-MONNAIE-LIBRE_35790.aspx

Pivot de Gauss

"En mathématiques, l'élimination de Gauss ou l'élimination de Gauss-Jordan, nommé en hommmage à Carl Friedrich Gauss et Wilhelm Jordan est un algorithme de l'algèbre linéaire pour déterminer les solutions d'un système d'équations linéaires, pour déterminer le rang d'une matrice ou pour calculer l'inverse d'une matrice carrée inversible. Lorsqu'on applique l'élimination de Gauss sur une matrice, on obtient sa forme échelonnée réduite." d'après wikipédia (http://fr.wikipedia.org/wiki/Élimination de Gauss-Jordan). Je n'aurais pas mieux dit 😉

L'application que j'ai faite moi même et son code source sont sur :

http://www.csharpfr.com/codes/METHODE-ELIMINATION-GAUSS-JORDAN-PIVOT-GAUSS-POUR-SYSTEMES_35153.aspx